Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища


НазваМетодичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища
Дата конвертації06.02.2013
Розмір445 b.
ТипМетодичні вказівки


«ВИКОРИСТАННЯ СЕРЕДОВИЩА FLASH ДЛЯ СТВОРЕННЯ АНІМАЦІЙНИХ МОДЕЛЕЙ МЕХАНІЗМІВ ВЕРСТАТІВ»

  • Методичні вказівки

  • до самостійної роботи

  • Коротун М.М. ТМВІ


Мета роботи

  • Ознайомитися з елементами середовища Flash, а саме з тією його частиною, яка дає можливість протягом одного заняття починати створювати анімаційні моделі механізмів верстата, таких як пересувні блоки зубчастих коліс, кулачкових муфт, шківів пасових передач, елементів гідропривода,тощо



Мета роботи (продовження)

  • засвоїти методику розкладання складних конструкцій верстата за шарами; за індивідуальним завданням виконати анімацію рухів вузла або механізма верстата з подальшим його використанням у наступних більш складних проектах.



Початок роботи з програмою Flash

  • Для початку роботи з програмою її потрібно встановити, якщо вона ще не встановлена, або відкрити, якщо на робочому столі комп’ютера є іконка програми такого вигляду:



Таким чином, як бачимо з іконки, ми працюватимемо з програмою



При натисканні на іконку відкривається вихідна панель програми



З цієї панелі на початковому етапі нам потрібна лише одна позиція, а саме: у середньому стовпчику Create New верхня позиція Flash Document



Усі інші позиції будемо розглядати поступово в міру їх потреби для використання, хоча самостійно можливе вивчення повністю усієї панелі



Ознайомлення з програмою Flash

  • Для відкриття основного робочого вікна програми натискаємо на кнопку Flash Document. Основне робоче вікно програми подане на наступному слайді. У даному випадку вікно значно зменшене, і тому розглядатимемо його фрагментами, заголовки яких подані на виносках





Головне меню програми Flash



Кожен з цих елементів має меню, що випадає. Наприклад, меню File має такий вигляд:



Наступним елементом головного меню є Modify, меню якого, що випадає, має вигляд:



Під час роботи з програмою можна навіть не звертатися до елемента меню Modify, а користуватися «гарячими клавішами», у даному випадку клавіша F8.



Елемент головного меню Control має меню, що випадає, такого вигляду:



Як бачимо з наведеного фрагмента меню Control, для початку роботи потрібні тільки дві опції, а саме: Play та Test Movie. Їх використовують для відтворення (візуалізації) рухів зробленої анімації, але між ними є різниця, суть якої стане зрозумілою пізніше.



Панель інструментів рисування програми Flash

  • Багатьом така панель інструментів знайома з інших графічних або рисувальних програм, та і символіка панелі така, що значна частина символів відразу зрозуміла. Для подальшої творчої роботи потрібно буде використовувати майже усі опції панелі.



На даному ж етапі визначимо ті з них, які потрібні для створення миттєвої (навчальної) анімації. Для цього потрібні лише дві – чотири опції, що мають символи:



Відомості про шари

  • Програма Flash працює із використанням шарів, тобто об’єкти анімації розділяють, наприклад, на рухомі частини та нерухомі й розміщують їх на окремих шарах (як на окремих прозорих аркушах паперу).



Безумовно, ми маємо справу з віртуальними шарами, що практично не мають товщини. При складанні шарів на екрані ми спостерігаємо цілісний об’єкт, хоча він і розділений за шарами.



Для рухомих створюють анімацію рухів на відповідному шарі чи шарах, а нерухомі залишаються нерухомими на своїх шарах і під час виконання анімації.



Для анімації верстатів та їх механізмів можуть бути потрібними декілька шарів, наприклад 10 – 15. Програма Flash дозволяє створювати та використовувати до сотні шарів.



При першому ознайомленні достатньо буде скористатися одним шаром. Робоче поле програми (див. слайд) - саме один (перший) шар, на якому можна показати створення миттєвої (навчальної) анімації.



Лінійка кадрів та шкала часу



Збільшений фрагмент



Незважаючи на те, що на фрагменті подані назви чотирьох нових елементів, необхідно зазначити, що для першого ознайомлення потрібне знання лише двох із них – це про шкалу кадрів з позначками через кожні п’ять кадрів та про ключовий кадр



Потрібно також додати, що перший кадр при відкритті програми, при створенні нового шару та на початку роботи завжди є ключовим. Таким чином, перелічених вище елементів програми Flash достатньо для створення первісної (миттєвої, навчальної) анімації.



Робота з програмою Flash

  • Набуття навичок роботи з програмою Flash будемо виконувати за кроками. Перший крок – набуття навичок відкриття та закриття програми. Якщо вихідна панель програми відкрита, підводимо курсор до Flash Document і натискаємо лівою кнопкою мишки один раз. Відкривається основне робоче вікно програми Flash.



Закриваємо програму через перехрестя у правому верхньому куточку основного робочого вікна програми або через елемент головного меню File, скориставшись опцією Clouse. Для набуття навичок повторити 5 - 8 разів. Закінчити тренування відкритим основним робочим вікном програми



Крок другий. Розміщення графічного елемента (прямокутника, квадрата, кола) на робочому полі. Для цього підводимо курсор до панелі інструментів рисування й установлюємо його на символі прямокутника. Натискаємо лівою кнопкою мишки на прямокутник. Курсор мишки переводимо на робоче поле і, натиснувши на ліву кнопку мишки та рухаючи її, будуємо прямокутник





Можна об’єднати два кроки: закрити програму після побудови прямокутника, відкрити її та знову побудувати прямокутник. Але на такий випадок при закритті програми з’являється повідомлення (наст. слайд) із запитанням про збереження зміненого файла.



Поруч із прямокутником на робочому полі віконце із запитанням про збереження зміненого файла



У даному випадку (при тренуванні) потрібно відповідати «нет». В інших випадках, коли будуть створюватися складні проекти, кожного разу необхідно бути уважним і подумати, чи потрібно зберігати зміни у проекті чи ні.



Крок третій. Виділення графічної фігури. Для виділення графічної фігури повертаємося до панелі інструментів і натискаємо на клавішу Виділення (Selection Tool)





Курсор переносимо на робоче поле так, щоб він розмістився вище лівого верхнього кута прямокутника. Натискаємо на ліву кнопку мишки та, утримуючи її, водночас переміщуємо курсор нижче правого нижнього кута прямокутника. При цьому автоматично утворюється рамка, зображена на слайді



Потрібно вказати, що рамка утворюється при постійно натиснутій лівій клавіші мишки. Якщо клавішу відтиснути, то рамка зникає, а прямокутник (його лінії та заливка) змінюють форму на таку, як показано на наступному слайді





Це означає, що графічний об’єкт виділений і з ним можна працювати далі. Можна додати, що виділений об’єкт можна переміщувати по всьому робочому полю



Завдання:

  • набуття навичок виділення графічного об’єкта та переміщення його по робочому полю. Об’єднати кроки перший, другий та третій



Крок четвертий. Перетворення графічного об’єкта на символ - Convert to Symbol.

  • Для цього використовуємо елемент головного меню Modify, меню якого, що випадає, має опцію Convert to Symbol. При натисканні на Convert to Symbol випадає ще одне меню (наст. слайд), у верхній частині якого можна присвоїти ім’я графічному об’єкту



Меню, що випадає при натисканні на Convert to Symbol меню Modify



За замовчуванням система автоматично присвоює графічному об’єкту ім’я. На слайді це ім’я Symbol 1. Залишається тільки натиснути на кнопку ОК, а це означає, що графічному об’єкту присвоєне саме це ім’я. Зверніть увагу на те, що під ім’ям є опція Type, яка у даному випадку визначає створення Movie Clip (рухомого зображення, кліпа).



Після відтискання ОК на робочому полі прямокутник набирає ще одну форму (наст. слайд) з невеликим колом усередині. На правій половині екрана, яку ми не розглядали, у вікні Library (бібліотека) теж з’являється креслення прямокутника, а під словом Name – ім’я – те, що присвоєно в опції Convert to Symbol



Зміна форми прямокутника після присвоєння йому ім’я Symbol 1



Поява прямокутника у вікні Library з ім’ям Symbol 1



Завдання:

  • набуття навичок присвоєння ім’я графічному об’єкту (наприклад, Vprava 1). Об’єднати кроки перший, другий, третій та четвертий.



Ключові кадри

  • Їх може бути декілька, а точніше стільки, скільки потрібно. Для найпростішої анімації достатньо двох ключових кадрів. Про перший ключовий кадр ми вже згадували і показали його розміщення на фрагменті (слайд )



Зверніть увагу, що якщо на фрагменті ()та на слайді ()ключовий кадр світлий, то на слайді () ключовий кадр темний (чорний). Став він темним (чорним) тоді, коли ми присвоїли графічному символу ім’я. Тобто справжній ключовий кадр – чорний, а те, що позначено на фрагментах раніше – місце під майбутній ключовий кадр.



На наведених слайдах ключовий кадр перший. Для програми це означає, що об’єкт з ім’ям Symbol 1 знаходиться у визначеному місці й «зафіксований» у першому ключовому кадрі.



Принципово об’єкт можна перемістити у будь – яке місце робочого поля, але він (об’єкт) залишається поки що зафіксованим у першому кадрі



Для анімації потрібно створити другий ключовий кадр. Для цього до шкали кадрів підводимо курсор і на будь – якому кадрі, наприклад 35, натискаємо на ліву клавішу миші



Колір 35 кадру змінився на синій, а першого ключового кадру на білий



Кадр із білого кольору зміниться на синій. При цьому перший ключовий кадр теж змінить колір із чорного на білий. Але 35-й кадр ще не є ключовим. Щоб зробити його ключовим, потрібно, утримуючи на ньому курсор натиснути на праву клавішу мишки, після чого з’явиться меню (наст. слайд), де потім натиснути на опцію Insert Keyframe, яка перетворить кадр 35 на ключовий (або на “гарячу клавішу” F6).





Після натискання на опцію Insert Keyframe 35-й кадр перетвориться на ключовий і набуде чорного кольору. Але при цьому вся шкала кадрів від 1-го до 35-го змінить колір на сірий, перший ключовий кадр позначиться точкою, а об’єкт знову набере форми виділеного (наст. слайд)





Після відтискання клавіші мишки об’єкт приймає вихідної форми. Крок п’ятий – створення другого ключового кадру. Для цього потрібно виконати перелік дій, що подані на слайді 17. Завдання: набуття навичок створення другого ключового кадру



Створення анімації

  • З попереднього пояснення про ключові кадри нам відомо, що об’єкт був зафіксований у першому ключовому кадрі з присвоєним ім’ям та місцем розміщення. При створенні другого ключового кадру об’єкт змінював свою форму, тобто реагував на появу другого ключового кадру. Відтепер якщо ми перемістимо об’єкт в інше місце, то це місце автоматично буде зафіксоване у другому ключовому кадрі. Цим переміщенням ми показуємо або створюємо шлях майбутнього переміщення в анімації (натупн. слайд)



Положення об’єкта у першому та другому ключових кадрах



Можна і потрібно виконати таку перевірку: якщо курсор поставити на перший ключовий кадр та натиснути на ліву клавішу мишки, то об’єкт миттєво повернеться у положення, де він був зафіксований у першому ключовому кадрі.



При виконанні цієї самої процедури для другого ключового кадру об’єкт миттєво переміститься у положення, де він зафіксований у другому ключовому кадрі. Для створення анімації руху об’єкта залишається натиснути на праву клавішу мишки при положенні курсора на будь – якому ключовому кадрі та вибрати опцію Create Motion (слайд)





Свідченням того, що анімація створена, є поява стрілки на шкалі кадрів між першим та другим ключовими кадрами (наст. слайд).





Крок шостий. Виконання дій та набуття навичок створення анімації: переміщення об’єкта в нове положення; поперемінне положення курсора на першому та другому ключових кадрах; використання опції Create Motion і спостерігання появи стрілки на шкалі кадрів.



Візуалізація створеної анімації

  • Повертаємося до останнього запланованого нами елемента головного меню Control, що має опції Play та Test Movie.



Як опція Play, так і опція Test Movie відтворюють (візуалізують) рухи анімації, але різниця між ними полягає у тому, що опція Play відтворює рух безпосередньо на робочому полі, а опція Test Movie імітує відображення анімації через Flash Player на допоміжному вікні - екрані.



На наступному слайді зафіксовано відтворення анімації з використанням опції Play головного меню Control. На шкалі кадрів з’явився маркер покадрового переміщення.





Під час використання опції Test Movie на робочому полі з’являється допоміжне вікно – екран, на якому в безперервному режимі відображується створена анімація. Зафіксований фрагмент такого випадку подано на наст. слайді



Допоміжне вікно – екран, на якому в безперервному режимі відображується створена анімація під час використання опції Test Movie



Крок сьомий. Набуття навичок відтворення (візуалізації) створеної анімації з використанням елемента головного меню Control та опцій Play і Test Movie.



Завдання:

  • повторити покрокове створення анімації з використанням інших графічних елементів (наприклад, кола) та змінюючи їх форму та заливку різним кольором.



Заливку різним кольором пропонується вивчити та виконувати самостійно, користуючись панеллю інструментів для рисування. Натиснувши на кнопку «заливка кольором» (Fill Color) (слайд ), можна отримати будь – який із запропонованих кольорів.



Створення анімаційних моделей механізмів верстата

  • Створення анімації будь -якого найпростішого механізму верстата, наприклад, переміщення блока на два

  • перемикання (рис.), потребує розділення його на об’єкти рухомі та нерухомі.



Блок повинен рухатися поздовж вала, а вал при цьому залишається нерухомим. У такому випадку об’єкти потрібно розмістити на окремих шарах. Тому розглянемо роботу із шарами.



На попередніх слайдах ми вже зустрічалися із поняттям «шар» та місцем його розміщення на шкалі Timeline (слайд ). Щоб створити новий шар, достатньо натиснути на іконку на шкалі Timeline.





На слайді другий шар створений над першим. Автоматично (за замовчуванням) шарам присвоєні імена Layer 1 та Layer 2. Безумовно, для простих об’єктів, розбитих на два шари, можна запам’ятати, що на першому шарі створюємо вал, а на другому – блок.



Для більшої кількості об’єктів ім’я Layer з порядковим номером буде стримувати (ускладнюватиме) роботу з анімації. Тому програмою передбачене надання свого ім’я кожному шару (наст. слайд).



Створення нового імені шару



Для того, щоб присвоїти ім’я будь – якому шару, потрібно перевести курсор на ім’я шару Layer та двічі клікнути лівою клавішею мишки. На білому віконці, що з’явиться, видалити ім’я Layer і набрати нове ім’я так, як, наприклад, показано на слайді



Зверніть увагу, на другому шарі теж уже є перший ключовий кадр. Потрібно пам’ятати, що об’єкти верхнього шару перекриватимуть об’єкти нижнього шару, якщо об’єкти верхнього шару не прозорі.



Створюємо механізм

  • Переходимо на перший шар та на перший ключовий кадр. На панелі інструментів використовуємо функцію Line. На робочому полі проводимо лінію – це буде вал, довжиною приблизно як на слайді



Далі повторюємо кроки 3 та 4, але в меню Convert to Symbol об’єкту присвоюємо ім’я Вал. Для нерухомого об’єкта другий ключовий кадр не потрібен, але потрібен кінцевий кадр.



Вибираємо кінцевим кадром 20-й або 25-й, і в меню за кроком п’ятим натискаємо на опцію Insert Frame (F5). Для побудови блока відкриваємо новий шар, даємо йому назву Блок і будуємо блок у першому ключовому кадрі з двох прямокутників та проводимо коротку лінію як на 86 слайді



Далі виконуємо відомі кроки з 3-го до 7-го. Один із фрагментів кінцевого результату подано нижче.



Завдання: виконати анімації механізмів верстатів за індивідуальним завданням Список літератури 1. Финкельштейн Э. Macromedia Flash 8 для «чайников».: пер. с англ./ Финкельштейн Э. Лит Г. М.: Издательский дом «Вильямс», 2006. – 416 с. 2. www.dialtktika.com



Схожі:

Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconМетодичні вказівки до відкритого заняття Методичні вказівки до
Навчальна: повторити І узагальнити основні поняття з теми, закріпити вміння за електронною формулою атома визначати хімічний символ...
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconПрактикуми як технологія активізації самостійної роботи студентів Навчання це самоосвіта, яка ґрунтується на самостійній роботі учнів
Вміння студента самостійно мислити, здобувати знання, проводити дослідження формується організаційною та методичною структурою самостійної...
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconМетодичні вказівки щодо організації та порядку проведення перевірок роботи реєстраторів цін. Прозорість та гласність
Методичні вказівки щодо організації та порядку проведення перевірок роботи реєстраторів цін
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconМетодичні засади комп’ютеризації самостійної роботи старшокласників у процесі вивчення програмного забезпечення математичного призначення Актуальність дослідження
...
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconДопомагати, полегшувати,сприяти, створювати умови для самостійної роботи. Учитель не інформатор, а організатор самостійної роботи з учнями
Рефлексія пов'язана із самопізнанням суб'єкта, аналізом ним свого внутрішнього стану
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconКурсова робота на тему: «організація самостійної роботи учнів під час вивчення інформатики в старшій школі»
Предмет дослідження – дидактичні основи й методика застосування енмк на уроках інформатики. Мета роботи – теоретично обґрунтувати...
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconПрограма для тестування знань і самостійної роботи "Тезаурус" автор проекту к т. н., доцент Паламарчук Є. А. Початок роботи проекту 2002 р
Відсутність необхідності інсталяції програми незалежність її від версії операційної системи
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconОрганізація роботи з вивчення, узагальнення й поширення досвіду
Методичні комісії це давня традиційна форма роботи, спрямована на вдосконалення науково теоретичної і методичної підготовки педпрацівників,...
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconМета роботи Мета роботи
Удосконалити систему харчової безпеки в умовах тов "Білоцерківський молочний комбінат"
Методичні вказівки до самостійної роботи Коротун М. М. Тмві мета роботи Ознайомитися з елементами середовища iconМета роботи: мета роботи
Встановити механізм формування бур’янового компононенту агрофітоценозу за різних систем землеробства

Додайте кнопку на своєму сайті:
dok.znaimo.com.ua


База даних захищена авторським правом ©dok.znaimo.com.ua 2013
звернутися до адміністрації
dok.znaimo.com.ua
Головна сторінка